Power the M7 from a 3.3 reg

Discussion related to "under the hood" OpenMV topics.
mjs513
Posts: 71
Joined: Sun Apr 30, 2017 12:52 pm

Power the M7 from a 3.3 reg

Postby mjs513 » Sun Aug 13, 2017 7:35 pm

Hi.

I have a rover that I am now powering the M7 from a 3.3v reg that goes into Vin, Gnd goes to gnd of the camera and the Teensy MCU that I am using to control the rover. The regulator is getting its power from the 7.4v lipo batter which also powers the rover electronics and the motors. Its working but the M7 processor is getting hot as hell and I am not sure why. Connections to the Teensy are through the uart (serial commications).

Any suggestions would be appreciated.

Thanks
mike
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Power the M7 from a 3.3 reg

Postby kwagyeman » Sun Aug 13, 2017 9:38 pm

As noted on the back of the board the OpenMV Cam M7 regulator is rated for 5V max.

You can however, push 3.3V into the OpenMV Cam M7 if you are not powering it via VIN. However, you must not connect USB/VIN power to it in this case.
Nyamekye,
mjs513
Posts: 71
Joined: Sun Apr 30, 2017 12:52 pm

Re: Power the M7 from a 3.3 reg

Postby mjs513 » Mon Aug 14, 2017 6:35 am

Think I shorted something out, because the chip is getting really hot and wanted to know if that was normal.

EDIT: Took it out of the system and tried it just on usb, thing heated up right away. Just ordered a replacement from your site.

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest