Fresh install on OSX 10.11: TypeError: function does not take keyword

Discussion related to "under the hood" OpenMV topics.
slow_one
Posts: 66
Joined: Fri Jun 02, 2017 11:25 am

Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby slow_one » Tue Jun 13, 2017 4:41 pm

I just downloaded and installed "openmv-ide-mac-1.6.0.dmg".
I plugged in my OpenMV Camera and started the IDE.
The IDE started up and I connected my camera. Once connected, I hit start... and got what looks like a single frame capture and an error popping up "TypeError: function does not take keyword arguments".
This is using the helloworld.py example that was preloaded on the camera.
Any suggestions would be appreciated.


EDIT:
I'm getting this as well:

PyDFU requires the following libraries to be installed:
MacPorts:
sudo port install libusb -py-pip
sudo pip install pyusb

HomeBrew:
sudo brew install libusb python
sudo pip install pyusb



Now... I already have python and pip installed on this system ... and trying to install via Port gives me an error, "Error: Port libusb not found"


EDIT:
The Windows based IDE works just fine ...
And editing the 'main.py' function (the LED blinky default) lets me adjust light timing just fine ...
BUT
The IDE when running on the Mac gives an additional piece of text at the bottom that says that the The Firmware version is out of date (version 2.3.0 when seen on the Mac IDE) and then eventually will disconnect
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby kwagyeman » Tue Jun 13, 2017 8:31 pm

Both the will windows and Mac IDE should say the firmware version is out of date if it is. That said, if you bought an M7 just click the label that says the firmware is out of date and you'll be able to upgrade your cameras firmware to the latest. The IDE scripts work with the latest firmware.

As for the MAC disconnecting problem I think I finally have an idea of what's going on there and we'll have a fix for the next software release. I'm pretty sure the MAC kernel driver for VCP ports has a max ingress rate for bytes recieved per millisecond and drops packets once you go above this causing errors. I'll be modifying the IDE and firmware to work around this issue by splitting up IDE frame buffer reads into chunks. Newer Macs don't have this problem.
Nyamekye,
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby kwagyeman » Tue Jun 13, 2017 8:34 pm

Note that DFU programming is a fallback programming mode for you camera if you can't connect to our bootloader. You should have a problem with this with the new M7 boards. The M4 boards had a bootloader timeout that was too short. Using DFU on the M4 boards fixes this by updating the bootloader along with the firmware.
Nyamekye,
slow_one
Posts: 66
Joined: Fri Jun 02, 2017 11:25 am

Re: Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby slow_one » Wed Jun 14, 2017 8:44 am

firmware out of date


I did have to update the Windows IDE (uninstall manually... reinstall in the same directory) and then I was able to update the Firmware (using the Windows IDE to update the firmware).

Once the firmware was updated, I was able to get the camera to function on the Mac (without changing the IDE version).
So, that's good.


What's up with the Python errors though? Is that related to what you were talking about above with the bit rate?
pcls1026
Posts: 19
Joined: Tue Aug 22, 2017 1:33 am

Re: Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby pcls1026 » Tue Aug 22, 2017 2:03 am

I just received my openMV CAM M7. I ran the script file titled Helloworld_1.py. The following serial terminal output occurred;

Exception: IDE interrupt
MicroPython v1.8-4376-g4de7fa54 on 2017-03-26; OPENMV3 with STM32F765
Type "help()" for more information.
>>>

Traceback (most recent call last):
File "<stdin>", line 10, in <module>
TypeError: function does not take keyword arguments
MicroPython v1.8-4376-g4de7fa54 on 2017-03-26; OPENMV3 with STM32F765
Type "help()" for more information.
>>>

WHAT DO I DO??
User avatar
kwagyeman
Posts: 1175
Joined: Sun May 24, 2015 2:10 pm

Re: Fresh install on OSX 10.11: TypeError: function does not take keyword

Postby kwagyeman » Tue Aug 22, 2017 2:10 am

You need to update the camera firmware. See the out of date button on the bottom of the IDE and click update.
Nyamekye,

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest