Openmvide does not recognize internal disk

Discussion related to "under the hood" OpenMV topics.
jaume
Posts: 14
Joined: Sun May 28, 2017 5:03 pm
Location: Barcelona

Openmvide does not recognize internal disk

Postby jaume » Thu Jun 08, 2017 5:22 pm

Hello
Follow the topic OpenMV Cam M7micro very hot
With the jumper YES recognize a dfu device, both in Windows and Linux, but if you remove the jumper, it stays blue blinking and does not recognize internal disk. OpenmvIDE I open it as administrator or root.
During the firmware recording, should the led flash ?
It is possible to reprogram the firmware with another application ?
Should bootloader.bin, firmware.bin, and openmv.bin be reprogrammed ?
Help me, please.
Jaume
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Fri Jun 09, 2017 1:34 am

I doubt any other forum member knows.

As I've said the device functionality seems fine. But, I have no idea what it does not work for you.
Nyamekye,
jaume
Posts: 14
Joined: Sun May 28, 2017 5:03 pm
Location: Barcelona

Re: Openmvide does not recognize internal disk

Postby jaume » Sun Jun 11, 2017 6:59 am

I have rescheduled the device with other applications and still the same, it recognizes the DFU mode but not the internal usb device.
It writes perfectly openmv.dfu, so it must be hardware failure on the STM32F765. The led is turned on in white, then on red and led blue flashing.
We will try another openmv cam.
Thank you for your interest and patience.
Jaume
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Sun Jun 11, 2017 12:08 pm

What are you doing exactly? Can you explain? In detail?
Nyamekye,
jaume
Posts: 14
Joined: Sun May 28, 2017 5:03 pm
Location: Barcelona

Re: Openmvide does not recognize internal disk

Postby jaume » Wed Jun 21, 2017 5:41 am

After several days without running (no flash leds) and without being recognized DFU mode, today finally, taking the openmv cam and pressing with the fingers on the USB connector (?), Has recognized the DFU mode.
As I said, with sudo pyhton pydfu.py, list, delete and save the file openmv.dfu, but once removed the jumper no longer communicates with openmv ide and the pc does not recognize the internal usb disk. Only the blue led flashes.
The openmvcam works with sd card. I record the sample file on the sdcard as main.py I put it in openmv and that's it.
Clearly I can not debug and burn directly because it still does not recognize the internal disk.
Nothing else, I'm waiting for a new openMV because I still believe it is a good product
Thanks for your patience
Jaume
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Wed Jun 21, 2017 11:15 am

Mmm, we've noticed a firmware issue with the internal disk not being reconginized. I believe we can fix this if we can get an idea of what the problem is. Can you open a bug on the OpenMV GitHub.

... About random issues, your an early adopter buying the camera right now. Sorry about having them.
Nyamekye,
jaume
Posts: 14
Joined: Sun May 28, 2017 5:03 pm
Location: Barcelona

Re: Openmvide does not recognize internal disk

Postby jaume » Wed Jun 21, 2017 5:21 pm

Reprograming with ST FlashLoader usb-serial
Work with the sdcard but without it the blue led flashes blue.
I go a few days to the mountain because here in Barcelona it is very hot.
See you soon
Bye
Attachments
Foto0974_2.jpg
success
Foto0974_2.jpg (20 KiB) Viewed 3207 times
Foto0974_1.jpg
downloading
Foto0974_1.jpg (17.72 KiB) Viewed 3207 times
Foto0974_0.jpg
conected to PC with usb-serial
Foto0974_0.jpg (26.26 KiB) Viewed 3207 times
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Wed Jun 21, 2017 9:32 pm

Note, when you reprogram with the OpenMV.dfu file you should not have the SD card inserted. This will cause issues...
Nyamekye,
jaume
Posts: 14
Joined: Sun May 28, 2017 5:03 pm
Location: Barcelona

Re: Openmvide does not recognize internal disk

Postby jaume » Fri Jul 14, 2017 1:31 pm

As you can see in the image, there is no sd card inserted.
With the openIDE, the sd card is not inserted either, and not reprogram.
The examples record them on the SD card externally, rename the file and then insert the sdcard into the camera and it works perfectly.
Can it be a compiler problem used for firmware?
Any configuration parameters of the STM32F765VI ARM Cortex M7 processor?

Mysteries of the electronica
Thanks to them, we learn more.
See you soon
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Sat Jul 15, 2017 12:44 am

Yes, we've noticed this issue but are unable to root cause since it happens irregularly. Ibrahim tried to find it but he cannot reproduce. Hopefully updating MP in the future will fix this...
Nyamekye,
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: Openmvide does not recognize internal disk

Postby kwagyeman » Sun Jul 16, 2017 2:31 pm

I will be working on fixing this for the next release. This feature did work previously so looking through what code was changed should allow me to find what was broken. For now, please us and SD card to run your program on. The error doesn't happen with an SD card.
Nyamekye,

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests