Keypoints Editor Error

Discussion related to "under the hood" OpenMV topics.
ARedGear
Posts: 11
Joined: Tue Oct 01, 2019 4:56 pm

Keypoints Editor Error

Postby ARedGear » Tue Oct 01, 2019 5:03 pm

After I remove a handful of key points in the Keypoints Editor I get the following error: "Failed to save the edited keypoints for an unknown reason!"

... I've tried restarting my PC and all, but nothing.. any guidance would be helpful.

-Sean
User avatar
kwagyeman
Posts: 3832
Joined: Sun May 24, 2015 2:10 pm

Re: Keypoints Editor Error

Postby kwagyeman » Wed Oct 02, 2019 1:19 am

We haven't tested this feature out in years. Um, it's been basically un-maintained. Keypoints have not been a feature folks have been using of the camera.

Ibrahim is on a fishing trip right now but can debug when he gets back.
Nyamekye,
ARedGear
Posts: 11
Joined: Tue Oct 01, 2019 4:56 pm

Re: Keypoints Editor Error

Postby ARedGear » Wed Oct 02, 2019 9:56 am

Rodger that, I appreciate it!

that being said, what I'm trying to do is track a small feature change, a small rectangular actuation feature going from verticle (lets say 90 degrees) to a 60 degree state.

if keypoints isn't the way to track that, how would you recommend I go about that? I'd like to say have a green LED on when it's in the 90* state and red when it's in the 60* state.

Let me know your thoughts :)

If you'd like to share code I've provided a folder for you to be able to put samples in :)

https://drive.google.com/drive/folders/ ... sp=sharing
User avatar
kwagyeman
Posts: 3832
Joined: Sun May 24, 2015 2:10 pm

Re: Keypoints Editor Error

Postby kwagyeman » Wed Oct 02, 2019 10:21 am

Hi, everyone is asking for free code from us these days. We can no longer do this. Just provide pointers.

Um, I'd use the find_line segments method and filter the line segments returned and then track the appropriate one.
Nyamekye,
User avatar
iabdalkader
Posts: 1143
Joined: Sun May 24, 2015 3:53 pm

Re: Keypoints Editor Error

Postby iabdalkader » Thu Oct 03, 2019 2:01 pm

ARedGear wrote:
Tue Oct 01, 2019 5:03 pm
After I remove a handful of key points in the Keypoints Editor I get the following error: "Failed to save the edited keypoints for an unknown reason!"

... I've tried restarting my PC and all, but nothing.. any guidance would be helpful.

-Sean
Hi, I just tried the keypoints editor and it seems to be working fine. Are you editing a descriptor saved on the flash FS on the camera ? Note the editor creates backups of the descriptor+image before saving, you may run out of space if you're using the internal flash filesystem. Try copying the descriptor+image to PC first then edit.

Return to “Technical Discussion”

Who is online

Users browsing this forum: MSN [Bot] and 5 guests