LCD shield displays wrong color and bad quality

Discussion related to "under the hood" OpenMV topics.
aerialist
Posts: 4
Joined: Fri Jul 19, 2019 9:24 am

LCD shield displays wrong color and bad quality

Postby aerialist » Fri Jul 19, 2019 10:10 am

Just purchased official LCD shield last month and ran an example code (lcd_1.py) today.

The image on LCD is blur, colors are wrong and there are stripe noise.
Is this normal or did I get a faulty unit?

Frame Buffer view on Open MV IDE shows clear image. Disabling it doesn't help.

Yellow objects looks light blue and red looks blue on my LCD...
Attachments
IMG_7629.JPG
User avatar
kwagyeman
Posts: 3829
Joined: Sun May 24, 2015 2:10 pm

Re: LCD shield displays wrong color and bad quality

Postby kwagyeman » Fri Jul 19, 2019 12:34 pm

That seems to be a bad unit. Not sure how it passed testing. We check that these are okay.

Please contact us via email for a replacement.

(Hoping this ins't a systematic issue).
Nyamekye,
aerialist
Posts: 4
Joined: Fri Jul 19, 2019 9:24 am

Re: LCD shield displays wrong color and bad quality

Postby aerialist » Fri Jul 19, 2019 7:45 pm

Thank you Kwabena for your prompt support!
Will send an email.
User avatar
kwagyeman
Posts: 3829
Joined: Sun May 24, 2015 2:10 pm

Re: LCD shield displays wrong color and bad quality

Postby kwagyeman » Mon Jul 22, 2019 10:45 am

Hi, can you send me a picture of the QR code that you have on the back of your LCD shield? This will help us check how it was bad.
Nyamekye,
aerialist
Posts: 4
Joined: Fri Jul 19, 2019 9:24 am

Re: LCD shield displays wrong color and bad quality

Postby aerialist » Mon Jul 22, 2019 12:38 pm

Here it is.
Attachments
IMG_7633.JPG
User avatar
kwagyeman
Posts: 3829
Joined: Sun May 24, 2015 2:10 pm

Re: LCD shield displays wrong color and bad quality

Postby kwagyeman » Mon Jul 22, 2019 12:51 pm

Can I get a higher res pic of the QR code. My CM wants to see it so they can lookup the unit.
Nyamekye,
aerialist
Posts: 4
Joined: Fri Jul 19, 2019 9:24 am

Re: LCD shield displays wrong color and bad quality

Postby aerialist » Mon Jul 22, 2019 7:15 pm

Hope this works.
Attachments
EC6E748D-3790-4E58-B7D5-3FA4845C385F.jpeg
EC6E748D-3790-4E58-B7D5-3FA4845C385F.jpeg (24.17 KiB) Viewed 2324 times
User avatar
kwagyeman
Posts: 3829
Joined: Sun May 24, 2015 2:10 pm

Re: LCD shield displays wrong color and bad quality

Postby kwagyeman » Tue Jul 23, 2019 12:45 am

Thanks, sent it to our CM.
Nyamekye,

Return to “Technical Discussion”

Who is online

Users browsing this forum: Google [Bot] and 4 guests