Page 1 of 1

OpenMV porting on own board

Posted: Tue Jul 09, 2019 11:22 am
by ericchu923
Hello, I'm using Apollo F7(stm32f767igt6) for my custom board.
It has extend flash and SRAM on the board.
I also have question about usb problem.
When connect to PC, the board has detected com port in FS mode, but lost connect immediately.
So my question is:
1.How can I fix this problem?
2.Can I use extend flash and SRAM for more flash and RAM memory?
Any opinions are welcome.Thank you.
Eric

Re: OpenMV porting on own board

Posted: Tue Jul 09, 2019 2:21 pm
by kwagyeman
Um, so, if you are doing your own custom board we'd expect you to be a complete expert in what you are doing. Adding SRAM is hard. We will be releasing a camera with SRAM support soon. But, otherwise, you're on your own. I can't tell you why the USB is broken either. All this stuff is very hard.

Re: OpenMV porting on own board

Posted: Thu Jul 11, 2019 6:11 am
by ericchu923
kwagyeman wrote:
Tue Jul 09, 2019 2:21 pm
Um, so, if you are doing your own custom board we'd expect you to be a complete expert in what you are doing. Adding SRAM is hard. We will be releasing a camera with SRAM support soon. But, otherwise, you're on your own. I can't tell you why the USB is broken either. All this stuff is very hard.
Thanks for reply.
Actually,USB is not broken.
It has detected visual com port,but I don't know why don't have a flash drive pop up.
Maybe Mr.kwagyeman can tell me how openmv's filesystem works.
Anyway, thank you for the reply.
Eric

Re: OpenMV porting on own board

Posted: Thu Jul 11, 2019 1:58 pm
by kwagyeman
We really can't provide help support for custom firmware implementations. You are on your own here.

(To be honest, me and Ibrahim are stressed for time answering questions about our own product. We don't really have time to answer questions where it isn't our product).