LCD Shield causes M7/H7 Reset

Discussion related to "under the hood" OpenMV topics.
Chris19
Posts: 19
Joined: Tue Apr 23, 2019 5:28 pm

LCD Shield causes M7/H7 Reset

Postby Chris19 » Sun May 12, 2019 11:33 am

Good Day!

We're having trouble with our first OpenMV LCD Shield (v2 2/11/2016) received in April 2019.

When attached to any of our M7's or H7's (current firmware) - the cameras start and work properly.

However, when we run the "lcd_1.py" example program from the IDE, the cameras just reboot and disconnect from USB.

Two more LCD shields should arrive tomorrow, so we can try those and report back.

Any advice?

Thanks,
User avatar
iabdalkader
Posts: 1042
Joined: Sun May 24, 2015 3:53 pm

Re: LCD Shield causes M7/H7 Reset

Postby iabdalkader » Sun May 12, 2019 12:38 pm

Hi, by current firmware which one do you mean ? I can confirm 3.4.1 works (there might be an issue with the development firmware v3.4.2). Are you connecting another shield at the same time ? Some of the shields share pins and can't be used together. If not I think you may have a bad LCD shield, should wait and test the new shields to confirm.
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: LCD Shield causes M7/H7 Reset

Postby kwagyeman » Sun May 12, 2019 2:18 pm

Can you share pictures of how you've attached the LCD shields? We require these to be tested by our manufacturer.
Nyamekye,
Chris19
Posts: 19
Joined: Tue Apr 23, 2019 5:28 pm

Re: LCD Shield causes M7/H7 Reset

Postby Chris19 » Sun May 12, 2019 2:33 pm

Wow folks! Thanks for the lightning fast reply (again)!

Using firmware 3.3.1 that came along with IDE 2.2.0 and directly connecting the LCD shield to the cameras

Will wait and test with the new shields tomorrow, unless you advise otherwise.

Thanks!

PS - Love your lens protectors; especially useful when testing.
Image 2.png
Image 3.png
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: LCD Shield causes M7/H7 Reset

Postby kwagyeman » Sun May 12, 2019 2:52 pm

I see why you have problems. That's totally not the way we envisioned you mounting it.

Okay...

Since we've let folks mount stuff the way they have wanted I guess this should be documented more.

Um, so, you were supposed to use the long pin headers (female ones) and then the shield goes on the back of the camera. On the LCD product page the shield is attached like that.

I will add on the product page how to mount shields.
Nyamekye,
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: LCD Shield causes M7/H7 Reset

Postby kwagyeman » Sun May 12, 2019 2:57 pm

Image
Nyamekye,
Chris19
Posts: 19
Joined: Tue Apr 23, 2019 5:28 pm

Re: LCD Shield causes M7/H7 Reset

Postby Chris19 » Sun May 12, 2019 3:10 pm

Thanks for the clarification!!!

I feel very embarrassed :)
Chris19
Posts: 19
Joined: Tue Apr 23, 2019 5:28 pm

Re: LCD Shield causes M7/H7 Reset

Postby Chris19 » Sun May 12, 2019 3:21 pm

All your other shields mount on the 'lens' side of the camera; we just assumed the LCD was similar. Your clarification helps.

If that's the way the LCD Shields are supposed to mount to the cameras - how are we supposed to mount the camera to anything? Putting the LCD on the back-side perhaps enables someone to make a point-and-click camera, but makes mounting the system very difficult since the LCD now blocks all the mounting holes.

No worries - we'll just design our PCBs accordingly to accept all these connections, and re-route them as needed to the M7/H7's

Thanks again for the fast replies!
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: LCD Shield causes M7/H7 Reset

Postby kwagyeman » Sun May 12, 2019 3:26 pm

You are supposed to use the long female headers used in every picture of the camera.

We started providing male and female headers however since we had a customer called uARM who wanted the male pins. To make suppling easier we add both headers to the package the camera comes with.

...

As for mounting holes and whatnot. Um, I can't say that the hole locations were designed particularly well, but, we can't change the layout anymore (like Arduino).

I'd put the camera in the case and then add holes to the case to mount the camera better.

Sorry about that confusion. You should be able to desolder the pins easily and fix this.
Nyamekye,
Chris19
Posts: 19
Joined: Tue Apr 23, 2019 5:28 pm

Re: LCD Shield causes M7/H7 Reset

Postby Chris19 » Sun May 12, 2019 5:26 pm

No worries; all good.

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 6 guests