Smile detection not working?

Discussion related to "under the hood" OpenMV topics.
tylersuard
Posts: 2
Joined: Mon May 06, 2019 12:40 am

Smile detection not working?

Postby tylersuard » Mon May 06, 2019 12:43 am

Hello, I bought an M7 with the intention of using the smile detector example on it. When I attempt to use it, I get the following error: error.os, could not find file '/smile.network'.

Where do I get the file? How do I load it onto the board? Is there anything else I need to know before making it work?

Thanks,
Tyler
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: Smile detection not working?

Postby kwagyeman » Mon May 06, 2019 1:24 am

Hi, check in OpenMV IDE -> Tools -> Machine Vision -> CNN library. It should be in there. You have to copy it to disk on the camera.

That said, that example only kinda works. The face detector is great, but, the smile detection CNN isn't the most robust. The network isn't quite large enough to be that solid.

Um, I'm working right now on getting tensor flow lite ported to the camera. I've gotten all the code compiling and it seems to run. However, I need to rig up an example now showing folks how to make a network step by step. I was hoping to have an ETA for the new feature this weekend but I have to get Google to optimize their tensor flow for microcontroller code a bit more before it will be ready.
Nyamekye,
tylersuard
Posts: 2
Joined: Mon May 06, 2019 12:40 am

Re: Smile detection not working?

Postby tylersuard » Fri May 10, 2019 2:08 pm

Thank you. I appreciate that you take the time to answer every post. As a side question, is there a reason you chose to use the pyboard as a base, rather than the esp8266 or esp32? They have loads of flash and ram, in addition to being really cheap.

Thanks!
-Tyler
User avatar
iabdalkader
Posts: 1042
Joined: Sun May 24, 2015 3:53 pm

Re: Smile detection not working?

Postby iabdalkader » Fri May 10, 2019 8:43 pm

OpenMV cam is not based on pyboard, it uses the STM32H7 which has twice as much RAM and FLASH in the ESP32 and it's much faster.
User avatar
kwagyeman
Posts: 3522
Joined: Sun May 24, 2015 2:10 pm

Re: Smile detection not working?

Postby kwagyeman » Sat May 11, 2019 3:45 pm

We built the system a long time ago (2013). The EPS32 was not around back then.

If we had more folks provide software support we could switch to something else. However, it's just me and Ibrahim doing the bulk of the work.
Nyamekye,

Return to “Technical Discussion”

Who is online

Users browsing this forum: No registered users and 5 guests