Firmware upgrade on old M4 (2016) fails

Discussion related to "under the hood" OpenMV topics.
franx11
Posts: 4
Joined: Wed Apr 24, 2019 9:18 am

Firmware upgrade on old M4 (2016) fails

Postby franx11 » Wed Apr 24, 2019 9:22 am

I tried to upgrade my old M4 with the latest IDE and firmware, but after the process ran through there is only the white LED permanently flashing.
I did a downgrade to firmware 2.1 which worked. Any idea?

Thanks,
Frank
Seventiesguy
Posts: 2
Joined: Wed Apr 24, 2019 6:07 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby Seventiesguy » Wed Apr 24, 2019 6:10 pm

I also have this problem after updating my M4 firmware

...Pat
User avatar
iabdalkader
Posts: 1142
Joined: Sun May 24, 2015 3:53 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby iabdalkader » Wed Apr 24, 2019 7:21 pm

Do you have an M4 with OV7725 or OV2640 ?
franx11
Posts: 4
Joined: Wed Apr 24, 2019 9:18 am

Re: Firmware upgrade on old M4 (2016) fails

Postby franx11 » Thu Apr 25, 2019 5:45 am

Mine is an OV7725
User avatar
iabdalkader
Posts: 1142
Joined: Sun May 24, 2015 3:53 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby iabdalkader » Thu Apr 25, 2019 11:05 am

Hi,

If an older firmware works we know the hardware is fine... Can you try upgrading to 3.3.1 ? I just tested my M4/OV7725 and it works fine. Also if you have an SD card please remove it.
franx11
Posts: 4
Joined: Wed Apr 24, 2019 9:18 am

Re: Firmware upgrade on old M4 (2016) fails

Postby franx11 » Thu Apr 25, 2019 4:14 pm

I installed the latest IDE 2.2.0 and tried that firmware. Removing the SD card didn't change anything.

I also tried the manual install (tools/bootloader file \OpenMV IDE\share\qtcreator\firmware\OPENMV2\openmv.dfu).
User avatar
iabdalkader
Posts: 1142
Joined: Sun May 24, 2015 3:53 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby iabdalkader » Thu Apr 25, 2019 6:35 pm

franx11 wrote:
Thu Apr 25, 2019 4:14 pm
I installed the latest IDE 2.2.0 and tried that firmware. Removing the SD card didn't change anything.

I also tried the manual install (tools/bootloader file \OpenMV IDE\share\qtcreator\firmware\OPENMV2\openmv.dfu).
Okay I see the issue now, it happens when the internal filesystem is erased and the flash is formatted with the latest firmware. I'll work on debugging this but for now there's workaround if you want latest fw you can upload an older firmware image first (tested with 3.0) and check erase internal filesystem and then let the camera boot to create a fresh FS with the old firmware, and then update to the latest (3.3.1) but this time keep the internal fs.
User avatar
iabdalkader
Posts: 1142
Joined: Sun May 24, 2015 3:53 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby iabdalkader » Fri Apr 26, 2019 5:21 pm

Hi, the attached firmware should fix the issue.
Attachments
omv2_ffs_fix_firmware.zip
(560.12 KiB) Downloaded 76 times
franx11
Posts: 4
Joined: Wed Apr 24, 2019 9:18 am

Re: Firmware upgrade on old M4 (2016) fails

Postby franx11 » Sat Apr 27, 2019 1:58 pm

Thanks. Your previous post actually solved the issue.

Best regards,
Frank
Seventiesguy
Posts: 2
Joined: Wed Apr 24, 2019 6:07 pm

Re: Firmware upgrade on old M4 (2016) fails

Postby Seventiesguy » Sun May 05, 2019 5:22 pm

Tested new firmware on M4 OV7725 and now working.

Thanks
...Pat

Return to “Technical Discussion”

Who is online

Users browsing this forum: Scott and 2 guests