OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

General discussion about topics related to OpenMV.
dackley
Posts: 2
Joined: Tue May 15, 2018 1:51 pm

OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby dackley » Tue May 15, 2018 2:34 pm

Hello. I'm new to OpenMV and running OpenMV IDE version 1.9.0. on Windows 10 Pro x64. I just fired up my OpenMV Cam M4 OV7725 and updated it to Firmware Version 2.8.0. But the IDE still says "Firmware Version: 2.8.0 - [out of date - click here to upgrade]". I clicked it and got the message "Update your OpenMV Cam's firmware to the latest version? I clicked OK and got the message "Erase the internal file system?" I clicked Yes and it Erased/Programmed with the message "Done upgrading your OpenMV Cam's firmware! Click the Ok button... I clicked and got the message "Your OpenMV Cam's firmware is out of date. Would you like to upgrade? I clicked OK and the cycle repeated from "Erase the internal file system?"
This Firmware Version 2.8.0 seems to work OK.
But the OpenMV IDE version 1.9.0 keeps complains that my OpenMV Cam M4 OV7725 is out of date.
What should I do?
Thanks
User avatar
kwagyeman
Posts: 2282
Joined: Sun May 24, 2015 2:10 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby kwagyeman » Tue May 15, 2018 3:35 pm

Ah, yeah, Ibrahim didn't update the M4 firmware in the latest drop. The IDE assumes there's a new firmware for all 3 boards. So, the M4 firmware is out of date... Um, please ignore the IDE for now. The only way to fix this is to release a new M4 firmware.

(We didn't release one because new stuff doesn't fit).
Nyamekye,
User avatar
iabdalkader
Posts: 544
Joined: Sun May 24, 2015 3:53 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby iabdalkader » Tue May 15, 2018 5:58 pm

Actually we're going to stop releasing new firmware for the M4 because none of the new features work on it. The last firmware image for M4 is 2.8.0. I'd recommend getting an M7.
dackley
Posts: 2
Joined: Tue May 15, 2018 1:51 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby dackley » Thu May 17, 2018 4:12 pm

So are you saying that those of us that supported the OpenMV movement by buying the original OpenMV M4 are going to be simply cast aside and ignored?
User avatar
kwagyeman
Posts: 2282
Joined: Sun May 24, 2015 2:10 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby kwagyeman » Thu May 17, 2018 4:38 pm

No, I put a lot of effort into making fixes for the M4 into the latest firmware. We just have a lot of work to do on the driver side to shrink things back down again. We were rushing to release the M7 firmware before Maker Fair Bay area and Ibrahim skipped this part.

I can do a patch release for the M4 after Maker Fair for support for it.

That said, while I sense anger in your tone... We are quite literally out of firmware room on the M4. We can fix bugs on it as they are brought up but there's really no more space to add anything. We've put a lot of effort into adding ifdefs all over the code to keep it fititng... But, basically there's no new room.

In particular, I had the compile working for the M4 right before the release, but, the integration of the FLIR driver broke the build and I haven't had time to go back and fix it.
Nyamekye,
User avatar
iabdalkader
Posts: 544
Joined: Sun May 24, 2015 3:53 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby iabdalkader » Thu May 17, 2018 5:11 pm

So are you saying that those of us that supported the OpenMV movement by buying the original OpenMV M4 are going to be simply cast aside and ignored?
No, while we really appreciate your help getting this project off the ground, there's really nothing we can do here. It's Not laziness on our side, but none of the new features fit the M4's Flash/RAM, in fact we've actually been releasing *almost* the same firmware for the M4 for a while now (you just see updated fw numbers but there's nothing new). So unless there are bug fixes, 2.8.0 is the latest and the best we can do with the M4. However, we'll fix the IDE issue so you don't see this message again.
Garf
Posts: 3
Joined: Mon Sep 21, 2015 3:41 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby Garf » Tue May 29, 2018 9:53 am

Hi,

I am also having this problem, just went to upgrade the firmware as I probably haven't used it for a year and getting the same issue and assume its running firmware from last year. 2 questions...
1. how do I know which firmware is currently running?
2. Where is the latest firmware (assuming that the latest IDE has not upgraded it)?

Regards Gareth
User avatar
kwagyeman
Posts: 2282
Joined: Sun May 24, 2015 2:10 pm

Re: OpenMV IDE 1.9.0 says Firmware 2.8.0 out of date

Postby kwagyeman » Tue May 29, 2018 11:23 am

The IDE displays the firmware version the lower right hand corner of the IDE. The latest firmware version as of right now is 2.9.0.

We will be ramping the firmware version soon however with a new release and will fix this issue.
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 2 guests