IDE compiles and runs okay under opensuse

General discussion about topics related to OpenMV.
bogflap
Posts: 17
Joined: Mon Apr 16, 2018 10:03 am

IDE compiles and runs okay under opensuse

Postby bogflap » Tue May 08, 2018 8:57 am

FYI

I have managed to get the IDE (1.9.0) to compile and run using QtCreator 4.6.1. and QT 5.5.1 under opensuse Leap 42.2.
Obtained code using git clone --recursive https://github.com/openmv/openmv-ide.git
This includes being able to update the example ode and updating the firmware.
This is using an OpenMV M7 board.
User avatar
kwagyeman
Posts: 2116
Joined: Sun May 24, 2015 2:10 pm

Re: IDE compiles and runs okay under opensuse

Postby kwagyeman » Wed May 09, 2018 1:11 am

Cool, great to hear. Is there any issue on Open SuSe using the binaries?
Nyamekye,
bogflap
Posts: 17
Joined: Mon Apr 16, 2018 10:03 am

Re: IDE compiles and runs okay under opensuse

Postby bogflap » Thu May 10, 2018 4:46 am

No issue with using the the firmware binaries. Updated my M7 just like that.
Tried compiling the firmware but suse uses completely different program names for cross compiling.
Did not pursue that any farther as binaries are available on git.

Keep up the good work
User avatar
kwagyeman
Posts: 2116
Joined: Sun May 24, 2015 2:10 pm

Re: IDE compiles and runs okay under opensuse

Postby kwagyeman » Thu May 10, 2018 2:05 pm

Sorry, I meant the IDE binaries. Compiling the IDE is a lot of work. I had to setup two VERY special Linux VMs to make the software work on all Linux machines (basically I had to use the oldest libc possible and somehow compile while dealing with it).
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 5 guests