my openmv won't work ,but seems like it's not hardware damaged

General discussion about topics related to OpenMV.
drifterxxx
Posts: 2
Joined: Sat Mar 24, 2018 9:06 am

my openmv won't work ,but seems like it's not hardware damaged

Postby drifterxxx » Sat Mar 24, 2018 9:36 am

Here's the thing:
When i connect my openmv3 to my computer(with win system),the LED on openmv does not blink.There is a USB connetction,but no no extral disk apear in my computer.Still i click the "connect" button on openmvIDE ,it said"no openmv cam found",then"do you have an openmv connected and it bricked?",i click "yes",after that it let select the board type,ask me if i want to erase the internal file system,i choose "yes",i follow the instruction disconnect->connect,then it begin to erase something.after all this ,it should back to normal,but it sometimes report"out of memory".The matter is every thim i reconnet my openmv,i will do all this agian.Now it become worse ,when i at the "connect->reconnect" step,it will continue this step for seems like infinite.
I cant solve this myself, will anybody help me out?
User avatar
kwagyeman
Posts: 1771
Joined: Sun May 24, 2015 2:10 pm

Re: my openmv won't work ,but seems like it's not hardware damaged

Postby kwagyeman » Sat Mar 24, 2018 1:22 pm

What OS are you using? If it's a Mac... there was an issue with the IDE for a while we've finally fixed. I can give you a download link to a pre-release.
Nyamekye,
drifterxxx
Posts: 2
Joined: Sat Mar 24, 2018 9:06 am

Re: my openmv won't work ,but seems like it's not hardware damaged

Postby drifterxxx » Sun Mar 25, 2018 4:58 am

kwagyeman wrote:
Sat Mar 24, 2018 1:22 pm
What OS are you using? If it's a Mac... there was an issue with the IDE for a while we've finally fixed. I can give you a download link to a pre-release.
No it is not a Mac ,i use a windows7 system, I realize it may be a IDE problem ,i have not upgrade my IDE yet.
By the way ,i got another peoblem with my anoter openmv ,i can't open or delete the main.py file.In fact,i can delete it ,but next time connect my openmv,it show up again.But the openmv works fine when running code under the IDE.
User avatar
kwagyeman
Posts: 1771
Joined: Sun May 24, 2015 2:10 pm

Re: my openmv won't work ,but seems like it's not hardware damaged

Postby kwagyeman » Sun Mar 25, 2018 1:58 pm

Please upgrade your version of openmv ide and your openmv cam firmware.

The reason for not being able to delete the main.py file is because of a file system driver issues related to FAT12 file systems. In particular, you have to safety remove the OpenMV Cam flash drive when you modify any files on it using windows explorer. THis is not the case for FAT16/32 file system... i.e. more than 16 MB of disk. However, the internal uPy drive is so small that windows loads very old FAT12 file system drivers for it that were meant for floppy disks. In particular, windows doesn't flush writes to the disk unless you safety remove the disk in windows.

OpenMV IDE also forces windows to flush writes when you use it's "reset openmv cam" button under tools.
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 3 guests