IDE not getting target file from Windows Explorer

General discussion about topics related to OpenMV.
User avatar
dcolemans
Posts: 10
Joined: Fri Aug 25, 2017 9:43 am

IDE not getting target file from Windows Explorer

Postby dcolemans » Thu Sep 28, 2017 11:44 am

This is certainly a minor issue but one I'd like to see fixed. When I launch a program in Windows, my habit is to find the subject file in Windows Explorer and either double click (relying on the suffix file association) or drag the file to the target app on the desktop. OpenMV IDE doesn't play nice with this. It opens, but opens the last used .py program, not the target. I suspect the IDE isn't looking at what's passed to it.

Am I off base here? Or is it something that can be fixed?

Dave
User avatar
kwagyeman
Posts: 1248
Joined: Sun May 24, 2015 2:10 pm

Re: IDE not getting target file from Windows Explorer

Postby kwagyeman » Thu Sep 28, 2017 11:51 am

I've never seen this issue. Drag and drop works on my PC along with being able to open any file you like via the open menu.

Do you have steps to reproduce?

Note... I have not tried double click. OpenMV IDE doesn't own .py files.
Nyamekye,
User avatar
dcolemans
Posts: 10
Joined: Fri Aug 25, 2017 9:43 am

Re: IDE not getting target file from Windows Explorer

Postby dcolemans » Thu Sep 28, 2017 11:50 pm

I'm using Windows 7 and XP. The steps are these:
Run the IDE and Open Python program A.
Close the IDE.
Using Windows Explorer, select Python program B and Drag it onto the IDE desktop shortcut icon.
IDE opens with File A.

Seems that the IDE Always opens the last file it knew about.

Once I'm in the IDE, the menu Open works fine.
On my XP machine, I made it so the IDE does "own" .py files. So double clicking does open the IDE, just not with the program that was double clicked.

Dave
User avatar
kwagyeman
Posts: 1248
Joined: Sun May 24, 2015 2:10 pm

Re: IDE not getting target file from Windows Explorer

Postby kwagyeman » Fri Sep 29, 2017 1:42 am

Oh, okay, I'll fix this easily. I never designed it to handle this error. This has to do with how windows passes command line arguments to the IDE to open files. I know what's wrong.
Nyamekye,
User avatar
kwagyeman
Posts: 1248
Joined: Sun May 24, 2015 2:10 pm

Re: IDE not getting target file from Windows Explorer

Postby kwagyeman » Fri Sep 29, 2017 3:13 am

This has been fixed for the next version of OpenMV IDE.
Nyamekye,
User avatar
dcolemans
Posts: 10
Joined: Fri Aug 25, 2017 9:43 am

Re: IDE not getting target file from Windows Explorer

Postby dcolemans » Fri Sep 29, 2017 12:01 pm

Thanks Kwabena. You guys are the best!

Dave
User avatar
kwagyeman
Posts: 1248
Joined: Sun May 24, 2015 2:10 pm

Re: IDE not getting target file from Windows Explorer

Postby kwagyeman » Fri Sep 29, 2017 12:26 pm

I can send you the patched exe file tonight. Not sure if it will have linker issues though. You can try it and see if it works.
Nyamekye,
User avatar
dcolemans
Posts: 10
Joined: Fri Aug 25, 2017 9:43 am

Re: IDE not getting target file from Windows Explorer

Postby dcolemans » Fri Sep 29, 2017 12:34 pm

No hurry on the fix for me. I'l wait for the next IDE release.

Dave

Return to “General Topics”

Who is online

Users browsing this forum: Bing [Bot] and 1 guest