IDE install error and M7 cam wont run any examples

General discussion about topics related to OpenMV.
GOB
Posts: 16
Joined: Fri Oct 30, 2015 11:59 pm

IDE install error and M7 cam wont run any examples

Postby GOB » Fri Jul 21, 2017 3:53 pm

When I try to install the IDE, I get the follwing error:
"Error during installation process (org.qtproject.qtcreator.application): Execution failed(Unexpected exit code: 255): "cmd /c D:\My Documents HDD\OpenMV IDE5\share\qtcreator\drivers\dfuse.cmd"

It lets me complete the install if I hit "ignore" though.

When I plug in my M7 camera and try to run any example code (even "hello world") I get the following error:

"Type Error: Function does not take keyword argument"

I get this error when I try to run the camera on the previous version of the firmware as well.

I had my previous open mv cam M4 working well, I would love some help in getting my new M7 to work.
GOB
Posts: 16
Joined: Fri Oct 30, 2015 11:59 pm

Re: IDE install error and M7 cam wont run any examples

Postby GOB » Fri Jul 21, 2017 4:01 pm

I updated the firmware on the cam and now the code loads. Any update on the IDE installer issue though?
User avatar
kwagyeman
Posts: 3338
Joined: Sun May 24, 2015 2:10 pm

Re: IDE install error and M7 cam wont run any examples

Postby kwagyeman » Fri Jul 21, 2017 8:09 pm

DFUse is the DFU command loader driver install which helps you recover the OpenMV cam if it gets bricked. You can try to manually install if you'd like. Anyway, did you happen to write down the error code? I can use that to figure out if there's an error in the installer or if your system just rejects the driver.

If want to manually install go into the IDE install folder, share, QtCreator, DFUse, and you'll find the installer binaries there.
Nyamekye,
GOB
Posts: 16
Joined: Fri Oct 30, 2015 11:59 pm

Re: IDE install error and M7 cam wont run any examples

Postby GOB » Fri Jul 21, 2017 9:32 pm

Hi - thanks for the reply. All info about the error is in my first post.

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 5 guests