lcd shield doesn't work

General discussion about topics related to OpenMV.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

lcd shield doesn't work

Postby jisheng » Tue Apr 18, 2017 4:36 am

Re: Can the board works disconnected from IDE ?
Postby kwagyeman » Tue Oct 04, 2016 7:57 am
On my phone, so, short answer.

Click tools, and the then save to OpenMV cam. The IDE will then ask you if you want comments striped. Then go to tools and click reset OpenMV cam.

The board will now run the script you loaded onto it without the IDE
============================================================================================================================================================================================
Today,I try the steps as introduced above, but something happens to my board. The LCD shield doesn't show the picture as the picture showed in the ide. Does someone know what happens? How can i fix this problem? Thanks
User avatar
deshipu
Posts: 74
Joined: Sat Jan 09, 2016 5:36 am
Location: Zürich
Contact:

Re: lcd shield doesn't work

Postby deshipu » Tue Apr 18, 2017 6:49 am

You have to run the lcd example for this to work.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re:deshipu

Postby jisheng » Tue Apr 18, 2017 9:23 pm

I tried it just now, but it doesn't work still. :?
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Tue Apr 18, 2017 9:49 pm

Can you send us an image of the shield connected ?
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re:iabdalkader

Postby jisheng » Tue Apr 18, 2017 10:25 pm

Sure! I add it with the attachments. Can you see the picture?
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Tue Apr 18, 2017 10:38 pm

No can't see any attachments, also please include the script you used for testing.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re: iabdalkader

Postby jisheng » Tue Apr 18, 2017 10:45 pm

# Hello World Example
#
# Welcome to the OpenMV IDE! Click on the green run arrow button below to run the script!

import sensor, image, time

sensor.reset() # Reset and initialize the sensor.
sensor.set_pixformat(sensor.RGB565) # Set pixel format to RGB565 (or GRAYSCALE)
sensor.set_framesize(sensor.QVGA) # Set frame size to QVGA (320x240)
sensor.skip_frames(10) # Wait for settings take effect.
clock = time.clock() # Create a clock object to track the FPS.

while(True):
clock.tick() # Update the FPS clock.
img = sensor.snapshot() # Take a picture and return the image.
print(clock.fps()) # Note: OpenMV Cam runs about half as fast when connected
# to the IDE. The FPS should increase once disconnected.
=====================================================================================
how can I add the picture? I add it to the attachment and then submit, the picture cannot be upload to the post.
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Tue Apr 18, 2017 10:50 pm

Click Attachments -> Add files then browse for the image, it will upload and then submit
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Tue Apr 18, 2017 10:51 pm

You're not using the LCD at all in your script, unless there's a problem with the HW, this should work:

Code: Select all

import sensor, image, lcd

sensor.reset() # Initialize the camera sensor.
sensor.set_pixformat(sensor.RGB565) # or sensor.GRAYSCALE
sensor.set_framesize(sensor.QQVGA2) # Special 128x160 framesize for LCD Shield.
lcd.init() # Initialize the lcd screen.

while(True):
    lcd.display(sensor.snapshot()) # Take a picture and display the image.

jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re: lcd shield doesn't work

Postby jisheng » Tue Apr 18, 2017 11:05 pm

I tried the code you tell me.I think this time it works,but there are many stripes in the LCD shield. I cannot find the browse button in my web. Could you please tell me your email address, so that i can use the email to send you the picture. By the way, if I erase some thing by mistake, can it have an influence on the shield?
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Tue Apr 18, 2017 11:27 pm

You can upload it somewhere like (http://imgur.com/) and just post the link.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re: lcd shield doesn't work

Postby jisheng » Wed Apr 19, 2017 9:32 pm

IMG_1090.JPG
IMG_1090.JPG (1.92 MiB) Viewed 8441 times
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re:iabdalkader

Postby jisheng » Wed Apr 19, 2017 9:34 pm

hi, I post the picture. This is what the lcd shield like.
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: lcd shield doesn't work

Postby iabdalkader » Wed Apr 19, 2017 9:51 pm

Hi, this shield is Not original, did you buy this from Taobao ? We've seen many clones lately on Taobao, they use low quality parts and 2 layers PCBs for the camera board, but also they change the design, which could cause issues. I can't be sure what's wrong with the shield, as we didn't make it.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re:iabdalkader

Postby jisheng » Wed Apr 19, 2017 10:00 pm

Yes, I bought it from taobao. So do you have a formal distributor in China?
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: Re:iabdalkader

Postby iabdalkader » Thu Apr 20, 2017 5:56 pm

jisheng wrote:
Wed Apr 19, 2017 10:00 pm
Yes, I bought it from taobao. So do you have a formal distributor in China?
Yes, very soon we'll have a distributor in China, I'll let you know then.
jisheng
Posts: 33
Joined: Wed Apr 12, 2017 9:42 pm

Re: lcd shield doesn't work

Postby jisheng » Thu Apr 20, 2017 9:01 pm

OK,thanks.
User avatar
iabdalkader
Posts: 951
Joined: Sun May 24, 2015 3:53 pm

Re: Re:iabdalkader

Postby iabdalkader » Wed May 10, 2017 12:10 pm

jisheng wrote:
Wed Apr 19, 2017 10:00 pm
Yes, I bought it from taobao. So do you have a formal distributor in China?
Hey, we have a distributor in China now, you can order/pre-order directly from Seeed.
User avatar
kwagyeman
Posts: 3335
Joined: Sun May 24, 2015 2:10 pm

Re: lcd shield doesn't work

Postby kwagyeman » Wed Jun 21, 2017 11:16 am

We don't sell an LCD and keypad shield.
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 8 guests