5MP OV5640 sensor on STM32F765

General discussion about topics related to OpenMV.
User avatar
chrisPyres66
Posts: 138
Joined: Mon Jul 16, 2018 9:22 am
Location: France

5MP OV5640 sensor on STM32F765

Postby chrisPyres66 » Mon Jan 06, 2020 11:30 am

Dear all,

Awefull, I tested the last firmware V352 to save UXGA images with OV5640 on a STM32F765 in jpeg mode on SDCARD and it works.

The only thing is the subject is blured if the subject moves under indoor environnment.
I suppose the automative exposition time is set too long.

Do you you any idea to improve this ?
Thanks,
User avatar
iabdalkader
Posts: 1085
Joined: Sun May 24, 2015 3:53 pm

Re: 5MP OV5640 sensor on STM32F765

Postby iabdalkader » Mon Jan 06, 2020 12:07 pm

Hi, we're still working on the OV5640 driver, trying to get the FPS higher.
User avatar
kwagyeman
Posts: 3715
Joined: Sun May 24, 2015 2:10 pm

Re: 5MP OV5640 sensor on STM32F765

Postby kwagyeman » Mon Jan 06, 2020 12:41 pm

I'm actively working on getting the speed up. It's hard however since the OV5640 isn't as simple as the other Omnivision cameras. I've found how to get a 2x speed boost already but I need to unlock 2x more speed on top of that to hit the correct fps.
Nyamekye,
User avatar
chrisPyres66
Posts: 138
Joined: Mon Jul 16, 2018 9:22 am
Location: France

Re: 5MP OV5640 sensor on STM32F765

Postby chrisPyres66 » Tue Jan 07, 2020 6:18 am

Omnivision has ov5640 dev board like Gaia with a soft which can help because you have writed register in real time !

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 6 guests