Page 1 of 1

picture gets dark, when switching IR leds on

Posted: Thu May 09, 2019 10:52 am
by gogol
Hello,

just received my kickstarter H7 and getting familar with it.
I started playing with the helloworld.py example and realized, that when i switch on the LED(4) the picture of the camera gets immediately very dark.
Is there anything tied to the IR leds, changing the camera settings?

I know, that the lens has an IR filter mounted, so i expected almost no difference at all. So I assume, that switching the IR leds on, changes some exposure settings.

Thanks for any hint

Re: picture gets dark, when switching IR leds on

Posted: Thu May 09, 2019 1:52 pm
by kwagyeman
Hi, I can't duplicate this. I don't see the affect. Is your camera receiving enough power? Switching those LEDs on is a rather large current draw.

Anything I can look at?

Re: picture gets dark, when switching IR leds on

Posted: Fri May 10, 2019 3:20 am
by gogol
I checked into this.

I attach two screenshots showing code and result.

Without infrared LED the board draws 115mA, with IR LED switched on it draws 190mA. Voltage stays stable at 4.9V (from the USB port).

It makes totally no difference, if the LED are covered or not.

Re: picture gets dark, when switching IR leds on

Posted: Fri May 10, 2019 4:34 am
by gogol
Another test, while the IR-LED are totally covered (black paper and gaffer tape).
The camera show to a white wall. When starting without LED switched on, you see in the histogram how the exposure settings are getting optimized.
When the IR LED are switched on (while covered!!) the exposure gets configured in the same way, but after a short time exposure is set back.

Re: picture gets dark, when switching IR leds on

Posted: Fri May 10, 2019 11:35 am
by Nezra
i can confirm this happens to mine as well. i tried flashing the LED's as well with the snapshot and it made it marginally better, but in full dark or light, turning on the IR leds effectively over exposes the entire image.

Re: picture gets dark, when switching IR leds on

Posted: Fri May 10, 2019 12:11 pm
by iabdalkader
Hi, the IR LEDs are so powerful (we designed them this way to be used in the dark) that the some of the light just leaks into the sensor, even when covered. The leak is much less with the global shutter sensor (because its package is bigger and opaque) and more obvious with the OV sensor (which is too thin and there's lots of vias under the sensor) and it goes away completely when using the extension cable.
img_20190510_090204_1024.jpg

Note if you put some plastic electrical tape on the back of the sensor module it may help.

Re: picture gets dark, when switching IR leds on

Posted: Fri May 10, 2019 12:36 pm
by kwagyeman
In that image I pointed the camera way from the sensor and the image looked fine.