picture gets dark, when switching IR leds on

General discussion about topics related to OpenMV.
gogol
Posts: 3
Joined: Thu May 09, 2019 10:44 am

picture gets dark, when switching IR leds on

Postby gogol » Thu May 09, 2019 10:52 am

Hello,

just received my kickstarter H7 and getting familar with it.
I started playing with the helloworld.py example and realized, that when i switch on the LED(4) the picture of the camera gets immediately very dark.
Is there anything tied to the IR leds, changing the camera settings?

I know, that the lens has an IR filter mounted, so i expected almost no difference at all. So I assume, that switching the IR leds on, changes some exposure settings.

Thanks for any hint
User avatar
kwagyeman
Posts: 3045
Joined: Sun May 24, 2015 2:10 pm

Re: picture gets dark, when switching IR leds on

Postby kwagyeman » Thu May 09, 2019 1:52 pm

Hi, I can't duplicate this. I don't see the affect. Is your camera receiving enough power? Switching those LEDs on is a rather large current draw.

Anything I can look at?
Nyamekye,
gogol
Posts: 3
Joined: Thu May 09, 2019 10:44 am

Re: picture gets dark, when switching IR leds on

Postby gogol » Fri May 10, 2019 3:20 am

I checked into this.

I attach two screenshots showing code and result.

Without infrared LED the board draws 115mA, with IR LED switched on it draws 190mA. Voltage stays stable at 4.9V (from the USB port).

It makes totally no difference, if the LED are covered or not.
Attachments
H7-02.png
H7-01.png
gogol
Posts: 3
Joined: Thu May 09, 2019 10:44 am

Re: picture gets dark, when switching IR leds on

Postby gogol » Fri May 10, 2019 4:34 am

Another test, while the IR-LED are totally covered (black paper and gaffer tape).
The camera show to a white wall. When starting without LED switched on, you see in the histogram how the exposure settings are getting optimized.
When the IR LED are switched on (while covered!!) the exposure gets configured in the same way, but after a short time exposure is set back.
Attachments
OpenMV-H7-IR-LED.mp4
(1.82 MiB) Downloaded 41 times
Nezra
Posts: 5
Joined: Fri Apr 19, 2019 9:08 am

Re: picture gets dark, when switching IR leds on

Postby Nezra » Fri May 10, 2019 11:35 am

i can confirm this happens to mine as well. i tried flashing the LED's as well with the snapshot and it made it marginally better, but in full dark or light, turning on the IR leds effectively over exposes the entire image.
User avatar
iabdalkader
Posts: 834
Joined: Sun May 24, 2015 3:53 pm

Re: picture gets dark, when switching IR leds on

Postby iabdalkader » Fri May 10, 2019 12:11 pm

Hi, the IR LEDs are so powerful (we designed them this way to be used in the dark) that the some of the light just leaks into the sensor, even when covered. The leak is much less with the global shutter sensor (because its package is bigger and opaque) and more obvious with the OV sensor (which is too thin and there's lots of vias under the sensor) and it goes away completely when using the extension cable.
img_20190510_090204_1024.jpg

Note if you put some plastic electrical tape on the back of the sensor module it may help.
User avatar
kwagyeman
Posts: 3045
Joined: Sun May 24, 2015 2:10 pm

Re: picture gets dark, when switching IR leds on

Postby kwagyeman » Fri May 10, 2019 12:36 pm

In that image I pointed the camera way from the sensor and the image looked fine.
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 4 guests