UVC mode couldn't work on openmv3 M7

General discussion about topics related to OpenMV.
lmaybefly
Posts: 4
Joined: Mon Feb 18, 2019 9:05 pm

UVC mode couldn't work on openmv3 M7

Postby lmaybefly » Mon Feb 18, 2019 9:25 pm

Hi,
I'm trying to let openmv enter UVC mode, uvc.bin had been flashed and instead of the firmware.bin.
After that, I can find the device via `lsusb` about "1209:abd1 InterBiometrics", and a new devnode(/dev/video1).
But guvcview could not open the preview. It show the device info: "OpenMV UVC in FS Mode: OpenMV U", and that background terminal prints "V4L2_CORE: (get_v4l2_frame) video stream must be started first" all the time. It's not work on Windows10 either.
I had found that same question with UVC mode on https://forums.openmv.io/viewtopic.php?f=3&t=1058, but can't see the final solution/result.
Could you help me? Thanks.
User avatar
kwagyeman
Posts: 3132
Joined: Sun May 24, 2015 2:10 pm

Re: UVC mode couldn't work on openmv3 M7

Postby kwagyeman » Mon Feb 18, 2019 10:13 pm

Ibrahim should be able to help you in this. I'm not sure what the exact state of this feature is.
Nyamekye,
lmaybefly
Posts: 4
Joined: Mon Feb 18, 2019 9:05 pm

Re: UVC mode couldn't work on openmv3 M7

Postby lmaybefly » Tue Feb 19, 2019 12:10 am

ok, thanks
User avatar
iabdalkader
Posts: 883
Joined: Sun May 24, 2015 3:53 pm

Re: UVC mode couldn't work on openmv3 M7

Postby iabdalkader » Tue Feb 19, 2019 10:47 am

Hi,
Try guvcview -d /dev/video0
lmaybefly
Posts: 4
Joined: Mon Feb 18, 2019 9:05 pm

Re: UVC mode couldn't work on openmv3 M7

Postby lmaybefly » Tue Feb 19, 2019 10:19 pm

Hi,

It works now. The root cause is USB hub.
If openmv connect Ubuntu directly without hub, qtcam/guvcview could open the new video device and show the preview().

But in windows10, the default camera app couldn't find openmv uvc camera even through device manager had recognized it.
Is there some differences of uvc implementation between linux and windows? If I want it to run on windows, what should I do?
Thanks.
User avatar
iabdalkader
Posts: 883
Joined: Sun May 24, 2015 3:53 pm

Re: UVC mode couldn't work on openmv3 M7

Postby iabdalkader » Wed Feb 20, 2019 12:15 pm

lmaybefly wrote:
Tue Feb 19, 2019 10:19 pm
Hi,

It works now. The root cause is USB hub.
If openmv connect Ubuntu directly without hub, qtcam/guvcview could open the new video device and show the preview().

But in windows10, the default camera app couldn't find openmv uvc camera even through device manager had recognized it.
Is there some differences of uvc implementation between linux and windows? If I want it to run on windows, what should I do?
Thanks.
Yes it doesn't work on Windows 7 or 10 and I'm not sure why (maybe a driver or camera app issue). However I managed to record video with ffmpeg build for windows.
lmaybefly
Posts: 4
Joined: Mon Feb 18, 2019 9:05 pm

Re: UVC mode couldn't work on openmv3 M7

Postby lmaybefly » Thu Feb 21, 2019 4:25 am

OK, I'll do some try.
Ronnye
Posts: 4
Joined: Mon Oct 22, 2018 2:48 am

Re: UVC mode couldn't work on openmv3 M7 with Windows 10

Postby Ronnye » Wed Jun 05, 2019 3:31 am

Hello,
I'd like to use the OpenMV Cam M7 with UVC firmware.

While I can successfully connect it and use it in Linux Ubuntu (with guvcview or Skype), I cannot make it work in Windows 10.
I saw that other people had the same problem.

Are there any news about it?

Thanks,
Ronnye
User avatar
iabdalkader
Posts: 883
Joined: Sun May 24, 2015 3:53 pm

Re: UVC mode couldn't work on openmv3 M7 with Windows 10

Postby iabdalkader » Wed Jun 05, 2019 10:45 am

Ronnye wrote:
Wed Jun 05, 2019 3:31 am
Hello,
I'd like to use the OpenMV Cam M7 with UVC firmware.

While I can successfully connect it and use it in Linux Ubuntu (with guvcview or Skype), I cannot make it work in Windows 10.
I saw that other people had the same problem.

Are there any news about it?

Thanks,
Ronnye
Yes it doesn't work on Windows for some reason, although it's just standard UVC...I got it working with ffmpeg however on Windows with directshow https://trac.ffmpeg.org/wiki/DirectShow

Return to “General Topics”

Who is online

Users browsing this forum: No registered users and 5 guests