Could not start openmvide on raspberry pi

General discussion about topics related to OpenMV.
mli
Posts: 2
Joined: Fri May 17, 2019 4:44 pm

Could not start openmvide on raspberry pi

Postby mli » Fri May 17, 2019 5:07 pm

Hi,

I just installed Qt5 and Qtcreator and then downloaded the OpenMV IDE from the website for Raspberripi 3. I followed the procedure provided by the README.txt in the openmv folder but get this error message after I execute the openmvide.sh----

This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted

Does anybody have idea for this error. Thank you in advance

max
User avatar
iabdalkader
Posts: 844
Joined: Sun May 24, 2015 3:53 pm

Re: Could not start openmvide on raspberry pi

Postby iabdalkader » Sun May 19, 2019 4:11 pm

Hi,

Could you try running the IDE from the terminal ?
User avatar
kwagyeman
Posts: 3055
Joined: Sun May 24, 2015 2:10 pm

Re: Could not start openmvide on raspberry pi

Postby kwagyeman » Mon May 20, 2019 1:17 am

Did you run the setup.sh? The xcb plugin backend is installed by that.
Nyamekye,
mli
Posts: 2
Joined: Fri May 17, 2019 4:44 pm

Re: Could not start openmvide on raspberry pi

Postby mli » Mon May 20, 2019 2:02 pm

Yes. It did. I tried to run on the terminal. I tried to run the executable file and the .sh both and the results are the same.

I did run the setup.sh before I run the executable file. I did install the Qt and Qt creator before I run the setup.sh.

By the way, the OpenMV runs on my Ubuntu computer. That is a great relief for me. But I hope it can be run on Raspberry PI.

Again, Thanks for your help!
User avatar
kwagyeman
Posts: 3055
Joined: Sun May 24, 2015 2:10 pm

Re: Could not start openmvide on raspberry pi

Postby kwagyeman » Mon May 20, 2019 2:42 pm

Hi, yeah, I can't reproduce a lot of the issues folks have on the Pi. Are you running raspbian? I've run the IDE on the default raspbian image, completely clean, no updates installed. And it works. I understand there are a lot of OSes you can install on the Pi however. I guess I could test the other OSes. That said, my time is really rather limited. I could use help in this regard and knowing what libraries are missing.
Nyamekye,
vannoolouis
Posts: 1
Joined: Thu May 23, 2019 4:44 am

Re: Could not start openmvide on raspberry pi

Postby vannoolouis » Thu May 23, 2019 4:50 am

I have a similar problem. When executing the setup.sh, it returns : "E: Impossible to get the lock /var/lib/dpkg/lock ..."
How could I fix this ?
User avatar
kwagyeman
Posts: 3055
Joined: Sun May 24, 2015 2:10 pm

Re: Could not start openmvide on raspberry pi

Postby kwagyeman » Thu May 23, 2019 10:25 am

Hi, that would imply your package manager is broken. In that situation... your operating system is seriously unstable. I would Google that particular error and look for a solution.
Nyamekye,

Return to “General Topics”

Who is online

Users browsing this forum: Bing [Bot] and 4 guests