Search found 16 matches

by otills
Thu Aug 29, 2019 8:10 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Perfect!! Many thanks.

Sleep is working well for me now with the most recent firmware you shared posted.
by otills
Tue Aug 20, 2019 9:06 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Ok thanks. Yeh I need to put the board to sleep for many minutes to get them to run for long enough on batteries for my application so 5 seconds is not useful. I will have to wait.
by otills
Tue Aug 20, 2019 2:25 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Hi, yes I’m using the firmware version you linked to here. I’m trying to wake from sleeps longer than 5000 ms so perhaps that’s the problem?
by otills
Tue Aug 13, 2019 5:55 pm
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Hi, unfortunately rtc.wakeup does not appear to be working.

Changes to the time appear to have no effect on the sleep duration - which is only a few seconds..

I have persevered with this as thought it might be an issue with my code, but do think that the rtc.wakeup is broken!
by otills
Tue Aug 13, 2019 1:53 pm
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Hi, given that that both setting and returning the date time via rtc.datetime() returns an invariant and incorrect datetime, can you confirm that the rtc.wakeup() with a given time period can be considered accurate in its periodicity over a prolonged period of numerous 'wakeups'?
by otills
Tue Aug 13, 2019 8:50 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Apologies for the multiple posts, but this also relates to RTC. No matter what I do with rtc.datetime, I get the date time (2000, 1, 1, 1, 0, 0, 0, 0) returned. I have tried various of the Example scripts in case the issue was with my own code, but as far as I can see this appears to be an issue wit...
by otills
Tue Aug 13, 2019 4:57 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

OK - I thought that I had fixed that sensor.reset() issue by using the IDE for doing a board reset (thinking that I must have broken something - perhaps attempting the deepsleep), but apparently not. Any attempt to put the sensor to sleep then throws this OSError: Reset Failed when it attempts to wa...
by otills
Tue Aug 13, 2019 4:24 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Hi, thanks for this - seems to work now.

Do you have an eta on deep sleep? Or, suggestions on any kind of intermediate steps to a low power state. I have tried the sensor.sleep() and sensor.shutdown() - directly from the Deep Sleep Mode Example script, and get "OSError: Reset Failed Reset Failed".
by otills
Mon Aug 12, 2019 2:04 pm
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Thanks.

I really appreciate you doing what you can. I have 8 x H7s all requiring this feature ASAP.
by otills
Mon Aug 12, 2019 9:42 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

OK - I would really appreciate an update when this is fixed - thanks for working on it. I am trying to deploy some OpenMV's to run in the environment for many weeks (with periodic video acquisitions)- are there any other approaches to reducing power consumption to levels that will make this possible...
by otills
Mon Aug 12, 2019 7:45 am
Forum: General Topics
Topic: Two Issues about autostart
Replies: 31
Views: 18220

Re: Two Issues about autostart

Has the issue with RTC been resolved as I cannot get rtc.wakeup() working at all?
by otills
Mon Aug 12, 2019 4:02 am
Forum: Technical Discussion
Topic: Reading data via ADC from temperature sensor
Replies: 9
Views: 3670

Re: Reading data via ADC from temperature sensor

Hi, thank you both for your help with this and apologies as It turns out that this was being caused by two non-OpenMV issues. 1) A mistake had been introduced in the line initialising the ADC -"P6" had been replaced with 6. 2) The sensor I was given is not an Atlas Scientific ENV-TEMP using ADC, but...
by otills
Fri Aug 09, 2019 12:24 pm
Forum: Technical Discussion
Topic: Reading data via ADC from temperature sensor
Replies: 9
Views: 3670

Re: Reading data via ADC from temperature sensor

OK - much appreciated. I will wait until either of you have had the chance to do this.
Thanks!
by otills
Fri Aug 09, 2019 11:18 am
Forum: Technical Discussion
Topic: Reading data via ADC from temperature sensor
Replies: 9
Views: 3670

Re: Reading data via ADC from temperature sensor

Thanks for that. Unfortunately no change with that firmware. The adc.read() output is the same regardless of whether anything is connected. Am I right in thinking that it should be working if powered over usb (I have tried with and without). I have also used a multimeter to confirm that the sensor i...
by otills
Fri Aug 09, 2019 10:21 am
Forum: Technical Discussion
Topic: Reading data via ADC from temperature sensor
Replies: 9
Views: 3670

Re: Reading data via ADC from temperature sensor

Hi, I don't know how to rebuild the firmware but could muddle through if pointed in the right direction. I have access to a Linux machine. I just tried on an up until now still packaged H7 board running the 3.2.0 firmware and get the same issue - was the issue introduced prior to this release? There...
by otills
Fri Aug 09, 2019 5:52 am
Forum: Technical Discussion
Topic: Reading data via ADC from temperature sensor
Replies: 9
Views: 3670

Reading data via ADC from temperature sensor

Hi, I have been playing with the OpenMV for about six months and am really blown away by what this small low powered board can do. That said, my experience on the electronics side is more limited and I am stuck on what I suspect is a simple problem I am attempting to get an OpenMV H7 to read data fr...

Go to advanced search