Search found 6 matches

by ky66111
Tue Jun 04, 2019 10:12 pm
Forum: Technical Discussion
Topic: Need explanation of nn.c
Replies: 3
Views: 3416

Re: Need explanation of nn.c

what's the range of p? in pixel metric like 0-255? If so, input_data = ((p - mean) << 7) + (1 << (input_scale - 1)) >> input_scale equals ((242 - 90) << 7) + (1 << 8)) >> 9 when p=242, mean=90, input_scale=9. The term including p supposes to be variance term and term of 1 << (input_scale - 1) is the...
by ky66111
Tue Jun 04, 2019 4:50 am
Forum: Technical Discussion
Topic: Need explanation of nn.c
Replies: 3
Views: 3416

Need explanation of nn.c

hello, here I come again. Thanks for your patience for the last several posts. My nn model still cannot work, so I run into openmv/src/omv/nn/nn.c and want to figure out how it works. In the nn_transform_input method, for (int y=0, i=0; y<data_layer->h; y++) { int sy = (y*y_ratio)>>16; for (int x=0;...
by ky66111
Wed May 15, 2019 1:51 am
Forum: Technical Discussion
Topic: OSError when read BMP
Replies: 1
Views: 3789

OSError when read BMP

I generate some bmp image from cifar lmdb database using opencv. But when reading bmp, exception throws out: "OSError: Unexpected value read!" import sensor, image, time # Still need to init sensor sensor.reset() # Set sensor settings sensor.set_contrast(1) sensor.set_gainceiling(16) # Set sensor pi...
by ky66111
Mon May 13, 2019 10:06 pm
Forum: Technical Discussion
Topic: input value doesn't match my neural network model
Replies: 5
Views: 5566

Re: input value doesn't match my neural network model

The compromising way that i've tried is to add a 1x1 conv layer with fixed params as scaling. But once I run the model, the board disconnects with IDE. Can you provide any possible reason for me to debug? This layer is probably not supported. I build a model with single such 1x1 conv layer. The ima...
by ky66111
Mon May 13, 2019 9:55 am
Forum: Technical Discussion
Topic: input value doesn't match my neural network model
Replies: 5
Views: 5566

Re: input value doesn't match my neural network model

I tried to retrain the non-normalized model, but the accuracy can't achieve my demand.
The compromising way that i've tried is to add a 1x1 conv layer with fixed params as scaling. But once I run the model, the board disconnects with IDE. Can you provide any possible reason for me to debug?
by ky66111
Fri May 10, 2019 4:34 am
Forum: Technical Discussion
Topic: input value doesn't match my neural network model
Replies: 5
Views: 5566

input value doesn't match my neural network model

hello, I train a regression model, from image to 3 number as output, and I want to deploy it on M7. My model was trained with caffe transform params that pixel value of 0-255 trans to 0-1, which the pixel value of Image class on the board does not match my input. But I found nothing with image pixel...

Go to advanced search